const regex = /^(?!\d+\.)(\w[\w\-]{0,24}\w)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+\\.)(\\w[\\w\\-]{0,24}\\w)\\.', 'gm')
const str = `estadão.com.br
domínio.com.br
90.com
-errado.com
aindaerrado-.com
OK.com
1.com.br
1a.org
łðµsdaf.com
estadao.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}