re = /^(?!\d+\.)(\w[\w\-]{0,24}\w)\./m
str = 'estadão.com.br
domínio.com.br
90.com
-errado.com
aindaerrado-.com
OK.com
1.com.br
1a.org
łðµsdaf.com
estadao.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end