using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+\.)(\w[\w\-]{0,24}\w)\.";
string input = @"estadão.com.br
domínio.com.br
90.com
-errado.com
aindaerrado-.com
OK.com
1.com.br
1a.org
łðµsdaf.com
estadao.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}