#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[^\t\n]*\t){3})(.*?)(?=\t\s*SM)"
Local $sString = " ID TO FROM BODY TYPE OTHER COLUMNS" & @CRLF & _
" 2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x" & @CRLF & _
" 2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")