import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^\\t\\n]*\\t){3})(.*?)(?=\\t\\s*SM)";
final String string = " ID TO FROM BODY TYPE OTHER COLUMNS\n"
+ " 2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x\n"
+ " 2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}