use strict;
my $str = ' ID TO FROM BODY TYPE OTHER COLUMNS
2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x
2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x ';
my $regex = qr/^((?:[^\t\n]*\t){3})(.*?)(?=\t\s*SM)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}