using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^\t\n]*\t){3})(.*?)(?=\t\s*SM)";
string input = @" ID TO FROM BODY TYPE OTHER COLUMNS
2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x
2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}