const regex = new RegExp('^((?:[^\\t\\n]*\\t){3})(.*?)(?=\\t\\s*SM)', 'gm')
const str = ` ID TO FROM BODY TYPE OTHER COLUMNS
2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x
2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}