import Foundation
let pattern = #"^((?:[^\t\n]*\t){3})(.*?)(?=\t\s*SM)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ID TO FROM BODY TYPE OTHER COLUMNS
2501 12345678910 12345678910 40m Test Content Here. SMxx x x x x x x x
2502 1234567891 1234567891 Varying Content Here. SMxx x x x x x x x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)