package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*+ Useless CSS \*+\/[^]*?END Useless CSS \*+\/\s*`)
var str = `/**** Useless CSS ****/
.my-class{
margin: 12px;
}
/* Several Lines after including other comments **/
/**** END Useless CSS ****/
.other {
padding: 12px;
}
/* Hello */`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}