$re = '/\/\*+ Useless CSS \*+\/[^]*?END Useless CSS \*+\/\s*/m';
$str = '/**** Useless CSS ****/
.my-class{
margin: 12px;
}
/* Several Lines after including other comments **/
/**** END Useless CSS ****/
.other {
padding: 12px;
}
/* Hello */';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;