# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*+ Useless CSS \*+\/[^]*?END Useless CSS \*+\/\s*"
test_str = ("/**** Useless CSS ****/\n"
".my-class{\n"
" margin: 12px;\n"
"}\n\n"
"/* Several Lines after including other comments **/\n\n"
"/**** END Useless CSS ****/\n\n"
".other {\n"
" padding: 12px;\n"
"}\n"
"/* Hello */")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.