const regex = /\/\*+ Useless CSS \*+\/[^]*?END Useless CSS \*+\/\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*+ Useless CSS \\*+\\\/[^]*?END Useless CSS \\*+\\\/\\s*', 'gm')
const str = `/**** Useless CSS ****/
.my-class{
margin: 12px;
}
/* Several Lines after including other comments **/
/**** END Useless CSS ****/
.other {
padding: 12px;
}
/* Hello */`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);