import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*+ Useless CSS \\*+\\/[^]*?END Useless CSS \\*+\\/\\s*";
final String string = "/**** Useless CSS ****/\n"
+ ".my-class{\n"
+ " margin: 12px;\n"
+ "}\n\n"
+ "/* Several Lines after including other comments **/\n\n"
+ "/**** END Useless CSS ****/\n\n"
+ ".other {\n"
+ " padding: 12px;\n"
+ "}\n"
+ "/* Hello */";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}