# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=<!--)([\s\S]*?)-->//gm;t' <<< "<!--
multi line html comment
-->
<!-- single line html comment -->
<!-- this is my blog: <mynixworld.inf> -->
<!--[if !(IE 8) ]><!-->"