use strict;
my $str = '<!--
multi line html comment
-->
<!-- single line html comment -->
<!-- this is my blog: <mynixworld.inf> -->
<!--[if !(IE 8) ]><!-->';
my $regex = qr/(?=<!--)([\s\S]*?)-->/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";