import Foundation
let pattern = #"(?=<!--)([\s\S]*?)-->"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!--
multi line html comment
-->
<!-- single line html comment -->
<!-- this is my blog: <mynixworld.inf> -->
<!--[if !(IE 8) ]><!-->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)