#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=<!--)([\s\S]*?)-->"
Local $sString = "<!--" & @CRLF & _
"multi line html comment" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"<!-- single line html comment -->" & @CRLF & _
"" & @CRLF & _
"<!-- this is my blog: <mynixworld.inf> -->" & @CRLF & _
"" & @CRLF & _
"<!--[if !(IE 8) ]><!-->"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)