using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<!--)([\s\S]*?)-->";
string substitution = @"";
string input = @"<!--
multi line html comment
-->
<!-- single line html comment -->
<!-- this is my blog: <mynixworld.inf> -->
<!--[if !(IE 8) ]><!-->";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}