$re = '/(?=<!--)([\s\S]*?)-->/m';
$str = '<!--
multi line html comment
-->
<!-- single line html comment -->
<!-- this is my blog: <mynixworld.inf> -->
<!--[if !(IE 8) ]><!-->';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;