package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^ABC(?: 1(?: 0|$))+$`)
var str = `ABC 1
ABC 1 0
ABC 1 0 1
ABC 1 0 1 0
ABC 1 1 1 1
ABC 0 0 0 0
ABC 1 0 0 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}