const regex = new RegExp('^ABC(?: 1(?: 0|$))+$', 'gim')
const str = `ABC 1
ABC 1 0
ABC 1 0 1
ABC 1 0 1 0
ABC 1 1 1 1
ABC 0 0 0 0
ABC 1 0 0 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}