re = /^ABC(?: 1(?: 0|$))+$/im
str = 'ABC 1
ABC 1 0
ABC 1 0 1
ABC 1 0 1 0
ABC 1 1 1 1
ABC 0 0 0 0
ABC 1 0 0 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end