using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ORA-\d*:\s*([^(,|\\n)]*)";
string substitution = @"$1";
string input = @"ORaaA-20005: Взаимосвязь по ORDERS(Заказ) с таким режимом уже существует
ORA-06512: at ""EDI.ADMIN_PKG"", line 608
ORA-065dada12: at line 1
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}