import re
regex = re.compile(r"ORA-\d*:\s*([^(,|\\n)]*)")
test_str = ("ORaaA-20005: Взаимосвязь по ORDERS(Заказ) с таким режимом уже существует\n"
"ORA-06512: at \"EDI.ADMIN_PKG\", line 608\n"
"ORA-065dada12: at line 1\n")
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)