// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"ORA-\d*:\s*([^(,|\\n)]*)").unwrap();
let string = "ORaaA-20005: Взаимосвязь по ORDERS(Заказ) с таким режимом уже существует
ORA-06512: at \"EDI.ADMIN_PKG\", line 608
ORA-065dada12: at line 1
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}