re = /ORA-\d*:\s*([^(,|\\n)]*)/
str = 'ORaaA-20005: Взаимосвязь по ORDERS(Заказ) с таким режимом уже существует
ORA-06512: at "EDI.ADMIN_PKG", line 608
ORA-065dada12: at line 1
'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result