#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\/)(\/[^\/]+\/|[^\/\n]+)(?:\/|$)"
Local $sString = "/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/" & @CRLF & _
"" & @CRLF & _
"/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//" & @CRLF & _
"" & @CRLF & _
"/string1/string2/string3//regexp1///regexp2///regexp3//string4/" & @CRLF & _
"" & @CRLF & _
"/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")