import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)(\\/[^\\/]+\\/|[^\\/\\n]+)(?:\\/|$)";
final String string = "/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/\n\n"
+ "/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//\n\n"
+ "/string1/string2/string3//regexp1///regexp2///regexp3//string4/\n\n"
+ "/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}