using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/)(\/[^\/]+\/|[^\/\n]+)(?:\/|$)";
string input = @"/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//
/string1/string2/string3//regexp1///regexp2///regexp3//string4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}