re = /(?<=\/)(\/[^\/]+\/|[^\/\n]+)(?:\/|$)/m
str = '/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//
/string1/string2/string3//regexp1///regexp2///regexp3//string4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end