const regex = /(?<=\/)(\/[^\/]+\/|[^\/\n]+)(?:\/|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/)(\\\/[^\\\/]+\\\/|[^\\\/\\n]+)(?:\\\/|$)', 'gm')
const str = `/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//
/string1/string2/string3//regexp1///regexp2///regexp3//string4/
/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}