import re
regex = re.compile(r"(?<=\/)(\/[^\/]+\/|[^\/\n]+)(?:\/|$)", flags=re.MULTILINE)
test_str = ("/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/\n\n"
"/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4//\n\n"
"/string1/string2/string3//regexp1///regexp2///regexp3//string4/\n\n"
"/string1/string2/string3//regexp1///regexp2///regexp3//string4//regexp4/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")