# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^.*(?:\R.*){2}\K/;/g;t' <<< "1
2
3
4
5
6
7
8
9"