using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^.*(?:\R.*){2}\K";
string substitution = @";";
string input = @"1
2
3
4
5
6
7
8
9";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}