use strict;
my $str = '1
2
3
4
5
6
7
8
9';
my $regex = qr/(?m)^.*(?:\R.*){2}\K/p;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";