$re = '/(?m)^.*(?:\R.*){2}\K/';
$str = '1
2
3
4
5
6
7
8
9';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;