const regex = /(?m)^.*(?:\R.*){2}\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^.*(?:\\R.*){2}\\K', 'g')
const str = `1
2
3
4
5
6
7
8
9`;
const subst = `;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);