#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2})$"
Local $sString = "ThisIsNotBase64Because/ItIsNotMod4" & @CRLF & _
"ThisIsBase64Because/ItIsMod4" & @CRLF & _
"ThisIsAlso/Base64+EvenWithPadding+==" & @CRLF & _
"ThisIsNotBase64+Because-ThereIsADash" & @CRLF & _
"YouGetTheIdea/=="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")