using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2})$";
string input = @"ThisIsNotBase64Because/ItIsNotMod4
ThisIsBase64Because/ItIsMod4
ThisIsAlso/Base64+EvenWithPadding+==
ThisIsNotBase64+Because-ThereIsADash
YouGetTheIdea/==";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}