re = /^(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2})$/m
str = 'ThisIsNotBase64Because/ItIsNotMod4
ThisIsBase64Because/ItIsMod4
ThisIsAlso/Base64+EvenWithPadding+==
ThisIsNotBase64+Because-ThereIsADash
YouGetTheIdea/=='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end