using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"T2G5P6";
string input = @"Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}