$re = '/T2G5P6/';
$str = 'Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);