re = /T2G5P6/
str = 'Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook '
# Print the match result
str.match(re) do |match|
puts match.to_s
end