package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`T2G5P6`)
var str = `Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}