#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))"
Local $sString = "s-sumnamessvc" & @CRLF & _
"s_somenames" & @CRLF & _
"s-somenameapp" & @CRLF & _
"s_somesvc" & @CRLF & _
"svc-wookir2d2" & @CRLF & _
"svc_wookic3p0" & @CRLF & _
"hansoloapp_svc" & @CRLF & _
"hansolomillenium-svc" & @CRLF & _
"sqldbsvc" & @CRLF & _
"svcappofsomesort" & @CRLF & _
"_somesvc" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")