// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))").unwrap();
let string = "s-sumnamessvc
s_somenames
s-somenameapp
s_somesvc
svc-wookir2d2
svc_wookic3p0
hansoloapp_svc
hansolomillenium-svc
sqldbsvc
svcappofsomesort
_somesvc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}