import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^\\-]*)\\W([^\\s]*)\\s+([^\\s]*)\\s+([^\\s]*)\\s+([^\\s]*)\\s+(.*$)";
final String string = "Jul 28 08:27:40 Mon-iWEB-R03-APS-01 authproc1_auth01 {\"actn\":76,\"pckId\":\"7a25f9c4bb39cacf\",\"sId\":\"354669705072900392110145246\",\"utId\":106854,\"did\":\"60b265bd68322e8c\",\"dvcc\":3,\"vsn\":\"139\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}