use strict;
my $str = 'Jul 28 08:27:40 Mon-iWEB-R03-APS-01 authproc1_auth01 {"actn":76,"pckId":"7a25f9c4bb39cacf","sId":"354669705072900392110145246","utId":106854,"did":"60b265bd68322e8c","dvcc":3,"vsn":"139"}';
my $regex = qr/(^[^\-]*)\W([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+(.*$)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}