import Foundation
let pattern = #"(^[^\-]*)\W([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+(.*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Jul 28 08:27:40 Mon-iWEB-R03-APS-01 authproc1_auth01 {"actn":76,"pckId":"7a25f9c4bb39cacf","sId":"354669705072900392110145246","utId":106854,"did":"60b265bd68322e8c","dvcc":3,"vsn":"139"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}